お知らせ:


 ◇ YouTube Apple Japan チャンネル で有用なヒントや使い方を配信中です。
 ◇ iOS 向け Apple サポート App のバージョン 2.4.1 が公開されました。

しばらく返答が寄せられていないようです。 再度ディスカッションを開始するには、新たに質問してください。

質問:

質問: Xcode7で使えるmasはありませんか?

Yosemiteのインストーラを再度ダウンロードするためにmasを使いたいのですが、masを使うにはXcode8以上が必要で、Xcode8にはEI Caption以上が必要のため、Yosemiteではmasを使うことができません。Xcode7で使えるmasというのは無いのでしょうか。Yosemiteを一旦EI Captionまで上げる以外に方法はありませんか?

OS X Yosemite (10.10.5)

投稿日

返信
スレッドに付いたマーク この回答で解決
回答:
回答:

ターミナルでls -laコマンドを叩き、出力された一覧に.bash_profileがあれば、そこにパスが指定(open .bash_profileで開けます)されてる(私の場合は、/usr/local/sbin)はずなので、Finderで/usr/local/sbinに解凍したmasを入れただけです。


それと、これを書き込む前に少し調べましたが、Yosemiteで動きますかね?

homebrewでインストール後に使おうとした時にどうなりました?

因みに、masを使ってもSierraリリース前にEl Capitanをダウンロードしたことがなければ無理だと思いますが、

OS X El Capitan をダウンロードする方法 - Apple サポート

からでもダウンロードできますよ。

https://itunes.apple.com/jp/app/os-x-el-capitan/id1147835434?mt=12

投稿日

スレッドに付いたマーク 参考になった

2017/11/26 22:39 el156 への返信 el156 への返信

サポート切れでも繋げられるはずですが。

又、おそらく無償サポートの内容だと思います。App Store のApple 側の問題なので。

有償か無償かは電話してから最終判断がされるはずです。有償のさいも有償である旨の説明があってからです。

スレッドに付いたマーク 参考になった

2017/11/26 22:40 el156 への返信 el156 への返信

masを使うにはXcode8以上が必要で、

そうなんですか? Sierra上のXcode ver7.2.1、mas ver 1.3.1でSierraのインストーラーをダウンロードして(その後masは必要なくなった)みましたが、問題なくダウンロードできた。 数日前にLion環境のApp StoreでもEl Capitanは購入済みに表示されてたので、mas云々ではなくApple IDとの関連付けを再確認すべきではないかと。

ディスカッションを部分的に表示しています

返信をすべて表示

ページコンテンツが読み込まれました

2017/11/18 14:28 el156 への返信 el156 への返信

直接、App Store からダウンロードできないのでしょうか。そのmas とやらを使いたい理由はなんでしょうか。

2017/11/18 14:28

返信 参考になった

2017/11/18 14:45 ni_ki への返信 ni_ki への返信

Yosemiteは元々AppStoreからダウンロードしたものですが、

今現在はAppStoreの購入済みアイテムに表示されません。


masはこちらで探しました。

https://applech2.com/archives/20170927-sierra-and-later-not-appear-purchased-tab.html

2017/11/18 14:45

返信 参考になった

2017/11/18 14:52 el156 への返信 el156 への返信

私のところではOS X El Capitan までは表示されているのでApple に問い合わせてみてはいかがでしょうか。ちなみにmacOS Sierra は前は表示されていましたが、今は表示されていなかったです。消された良うですね。

2017/11/18 14:52

返信 参考になった

2017/11/18 15:01 ni_ki への返信 ni_ki への返信

ありがとうございます。Appleに問い合わせるとMacのシリアルナンバーを聞かれ、答えるとシリアルが古い為にサポート切れでつないでもらえません。

2017/11/18 15:01

返信 参考になった
スレッドに付いたマーク 参考になった

2017/11/26 22:39 el156 への返信 el156 への返信

サポート切れでも繋げられるはずですが。

又、おそらく無償サポートの内容だと思います。App Store のApple 側の問題なので。

有償か無償かは電話してから最終判断がされるはずです。有償のさいも有償である旨の説明があってからです。

2017/11/26 22:39

返信 参考になった (1)
スレッドに付いたマーク 参考になった

2017/11/26 22:40 el156 への返信 el156 への返信

masを使うにはXcode8以上が必要で、

そうなんですか? Sierra上のXcode ver7.2.1、mas ver 1.3.1でSierraのインストーラーをダウンロードして(その後masは必要なくなった)みましたが、問題なくダウンロードできた。 数日前にLion環境のApp StoreでもEl Capitanは購入済みに表示されてたので、mas云々ではなくApple IDとの関連付けを再確認すべきではないかと。

2017/11/26 22:40

返信 参考になった (1)

2017/11/26 22:29 ni_ki への返信 ni_ki への返信

ありがとうございます。AppStore関連だと本体に関係なく問い合わせできるのですね。問い合わせしました。何度かやり取りがあって、質問は継続中です。丁寧に対応していただいていますが解決はしていません。

MavericksとYosemiteは表示されます。Sierraは表示されませんがsupport.apple.comからダウンロードできました。EI captionだけは、今のところ、masを使うしかダウンロードする方法がありません。

2017/11/26 22:29

返信 参考になった

2017/11/26 22:39 onesize への返信 onesize への返信

ありがとうございます。Xcodeのバージョンというよりも、MacOSのバージョンなのかもしれません。mas 1.3.1がEI caption以上を要求するようです。masのホームページへ行くともっと古いバージョンのmasもありますが、masをhomebrewでインストールするとmas 1.3.1になってしまいます。

App Storeの表示についてはAppleに問い合わせ中です。

2017/11/26 22:39

返信 参考になった

2017/11/26 23:00 el156 への返信 el156 への返信

古いバージョンのmas-cli.zipをダウンロードして任意の場所に移動すれば良いんじゃないかと。

私は、他のコマンドラインツールが在るディレクトリに入れました。 そうすればパスを通す必要もないので楽です。

2017/11/26 23:00

返信 参考になった

2017/11/26 23:26 onesize への返信 onesize への返信

お返事ありがとうございます。homebrewを使わずにmasをインストールするということでしょうか?

初歩的質問ですみません。昔仕事でemacsを使ったことがあるのでunixのコマンドラインツールはファイル操作程度ならわかりますが、インストールはhomebrewを使う方法しかやったことがありません。

2017/11/26 23:26

返信 参考になった
スレッドに付いたマーク この回答で解決

2017/11/27 00:38 el156 への返信 el156 への返信

ターミナルでls -laコマンドを叩き、出力された一覧に.bash_profileがあれば、そこにパスが指定(open .bash_profileで開けます)されてる(私の場合は、/usr/local/sbin)はずなので、Finderで/usr/local/sbinに解凍したmasを入れただけです。


それと、これを書き込む前に少し調べましたが、Yosemiteで動きますかね?

homebrewでインストール後に使おうとした時にどうなりました?

因みに、masを使ってもSierraリリース前にEl Capitanをダウンロードしたことがなければ無理だと思いますが、

OS X El Capitan をダウンロードする方法 - Apple サポート

からでもダウンロードできますよ。

https://itunes.apple.com/jp/app/os-x-el-capitan/id1147835434?mt=12

2017/11/27 00:38

返信 参考になった

2017/11/27 01:48 onesize への返信 onesize への返信

ご回答ありがとうございます。EI Captionは以前別のMacにインストールしたことがあります。リンク先では、「入手」ボタンを押すと「このバージョンのOSX 10.11は、このコンピュータにはインストールできません」となりました。YosemiteでもMavericksでも同じ結果でした。homebrewではmasインストール時にXcode8以上が必要というメッセージが出てmasのインストールを完了できませんでした。古いmasは、後でやってみます。

2017/11/27 01:48

返信 参考になった

2017/12/10 10:01 el156 への返信 el156 への返信

ありがとうございました。教えて頂いたた方法で古いmasを直接インストールできたのですが、結局最も古いmasでもSnowLeopardでは動作せず、先にSierraをインストールしてSierra上からmasでEI Captionをダウンロードできました。

2017/12/10 10:01

返信 参考になった
ユーザのユーザプロフィール: el156

質問: Xcode7で使えるmasはありませんか?