お知らせ:


 ◇ YouTube Apple Japan チャンネル で有用なヒントや使い方を配信中です。
 ◇ iOS 向け Apple サポート App のバージョン 2.4 が公開されました。

しばらく返答が寄せられていないようです。 再度ディスカッションを開始するには、新たに質問してください。

質問:

質問: Safariでかな文字入力ができない

・Safariから様々なサイトで、ネットショッピング等をする際に、入力フォームが表示されますが、その入力するボックスにかなで入力ができません。英数は入力が可能です。

入力して変換するとSafariが落ちてしまいます。

どなたか、解決方法を教えてください。


・アカウントを替えると問題がありません。

・Chromeでは問題がありません。

・IMEはOSに元々入っているもので、ライブ変換を使用しています。(ライブ変換機能をオフにしても同じ症状でした)

・Safari 11.0.1をiMac (Retina 5K, 27-inch, Late 2015)で使用しております。

・OSは 10.11.6 El Capitanです。


以上よろしくお願いいたします。

iMac, OS X El Capitan (10.11.2)

投稿日

返信
スレッドに付いたマーク この回答で解決
回答:
回答:

原因はわかりませんがとりあえず以下をお試しください。


・ セーフモードで起動する。

セーフモードを使って Mac の問題を切り分ける - Apple サポート


・ 機能拡張を無効にするかアンインストールする。

ブラウザをカスタマイズするための機能拡張を入手する - Apple サポート


・ 自動入力のその他のフォームを無効にするか編集する。

「Safari」の「自動入力」環境設定 - Apple サポート


・ Safari を終了してから ~/Library/Preferences/com.apple.Safari.plist をゴミ箱に移動して Mac を再起動する。特定の場所に移動するには「Finder」>「移動」>「フォルダへ移動」>「フォルダの場所を入力」にパス名をコピー&ペーストして「移動」をクリックする。

特定のフォルダに直接移動する - Apple サポート


・ 個々の Web サイトまたはすべての Web サイトの Cookie と Web サイトのデータを削除する。

「Safari」の「プライバシー」環境設定 - Apple サポート


・ 閲覧履歴を削除する(可能な場合)。

閲覧履歴をクリアする - Apple サポート

投稿日

スレッドに付いたマーク 参考になった

2017/12/06 23:34 kathirano への返信 kathirano への返信

解決して何よりです。


Safariの環境設定で、「自動入力」の「連絡先の情報を使用」と「その他のフォーム」のチェックを外し、無効にすることによって、問題が解決、ということですが、それらを有効にすると、今でもおかしくなりますか?

有効にしても、前の問題が再現しないなら良いのですが、通常はこれらを有効にしててもかな入力ができなくなるということはありませんので、もし有効にすると再発するようなら、何かkathiranoさんのマックに独自の問題がある可能性がありますので。

ディスカッションを部分的に表示しています

返信をすべて表示

ページコンテンツが読み込まれました

スレッドに付いたマーク この回答で解決

2017/12/06 20:56 kathirano への返信 kathirano への返信

原因はわかりませんがとりあえず以下をお試しください。


・ セーフモードで起動する。

セーフモードを使って Mac の問題を切り分ける - Apple サポート


・ 機能拡張を無効にするかアンインストールする。

ブラウザをカスタマイズするための機能拡張を入手する - Apple サポート


・ 自動入力のその他のフォームを無効にするか編集する。

「Safari」の「自動入力」環境設定 - Apple サポート


・ Safari を終了してから ~/Library/Preferences/com.apple.Safari.plist をゴミ箱に移動して Mac を再起動する。特定の場所に移動するには「Finder」>「移動」>「フォルダへ移動」>「フォルダの場所を入力」にパス名をコピー&ペーストして「移動」をクリックする。

特定のフォルダに直接移動する - Apple サポート


・ 個々の Web サイトまたはすべての Web サイトの Cookie と Web サイトのデータを削除する。

「Safari」の「プライバシー」環境設定 - Apple サポート


・ 閲覧履歴を削除する(可能な場合)。

閲覧履歴をクリアする - Apple サポート

2017/12/06 20:56

返信 参考になった (1)

2017/12/06 21:06 Rondo_1 への返信 Rondo_1 への返信

おかげさまで無事に解決しました。


Safariの環境設定で、「自動入力」の「連絡先の情報を使用」と「その他のフォーム」のチェックを外し、無効にすることによって、問題が解決しました。

しかしながら、自動入力のそれらの設定で、不具合が出るということは、対策をお願いしたいところですね。

ところで、その他の方法については、アップルのサポートを受けながら試してみましたが、解決せず、かなり沈鬱でありましたが、見事に解決され晴れ晴れしております。

実に丁寧で的確な解決方法のご提示に、感謝の極みであります。

本当にありがとうございました。

2017/12/06 21:06

返信 参考になった
スレッドに付いたマーク 参考になった

2017/12/06 23:34 kathirano への返信 kathirano への返信

解決して何よりです。


Safariの環境設定で、「自動入力」の「連絡先の情報を使用」と「その他のフォーム」のチェックを外し、無効にすることによって、問題が解決、ということですが、それらを有効にすると、今でもおかしくなりますか?

有効にしても、前の問題が再現しないなら良いのですが、通常はこれらを有効にしててもかな入力ができなくなるということはありませんので、もし有効にすると再発するようなら、何かkathiranoさんのマックに独自の問題がある可能性がありますので。

2017/12/06 23:34

返信 参考になった (1)

2017/12/06 22:19 kathirano への返信 kathirano への返信

原因まではわからないので当てずっぽうですが余裕があるときにでもアクセス権をリセットしてみてください。

ホームフォルダの中のアイテムのアクセス権を変更した後で起きる問題を解決する - Apple サポート


これも当てずっぽうですが最近の Safari だと ~/Library/Safari にある PerSitePreferences.db、PerSitePreferences.db-shm、PerSitePreferences.db-wal、PerSiteZoomPreferences.plist なども怪しい気がします(これ以外にもあると思います)。これは「Safari」>「環境設定」>「Web サイト」の設定のようなのですが com.apple.Safari.plis を捨てて Mac を再起動してもデフォルトにならないようです。

「Safari」の「Web サイト」環境設定 - Apple サポート

2017/12/06 22:19

返信 参考になった

2017/12/06 23:37 はに への返信 はに への返信

「連絡先の情報を使用」にチェックを入れ有効にすると、症状が再現されました。

とすると、はにさんの言われる通り、私のマック自体になんらかの問題があるということでしょうね。

これはこれで心配です。

サポートに連絡してみます。

ご指導ありがとうございました。

2017/12/06 23:37

返信 参考になった

2017/12/06 23:39 Rondo_1 への返信 Rondo_1 への返信

時間のあるときに試してみます。
未だに、元の環境に戻すと症状がありますので・・・
結果をご報告します。


貴重なご助言ありがとうございます。

2017/12/06 23:39

返信 参考になった
ユーザのユーザプロフィール: kathirano

質問: Safariでかな文字入力ができない