お知らせ:


 ◇ YouTube Apple Japan チャンネル で有用なヒントや使い方を配信中です。
 ◇ iOS 向け Apple サポート App のバージョン 2.4.1 が公開されました。

しばらく返答が寄せられていないようです。 再度ディスカッションを開始するには、新たに質問してください。

質問:

質問: 接続がプライベートではありません

よろしくお願いします。

webサイトへの接続ができず困っています。


端末:iMac 21.5-inch Late 2015 OS X El Captitan

ネットワーク:端末とルータを有線接続。回線はdokomo光。プロバイダはso-net。

ブラウザ:Mac OS付属のsafari。


症状は、”接続がプライベートではありません”と表示され、目的のサイト(Tモール)に接続されません。

携帯電話やポータブルゲーム端末からはTモールに問題なく接続できます。

そのため、iMacの設定(もしくはsafariの設定)の問題だと予想されます。

上記の警告表示の中で案内されている証明書の情報を確認すると、”tmall.tsite.jp”という証明書の発行者が不明とのこと。この証明書の有効期限は2019年ですので、まだ有効期限内です。

警告を無視して閲覧する方法も案内されているため、それに従って接続しても正しく表示されません。

例えば、絵や写真は表示されませんし、レイアウトもデタラメです。

このような症状になるサイトが他にも数件あります。(ちなみに、ほとんどのサイトには問題なく接続できています)

どなたか当該症状への対処方法をご存知の方がいらっしゃれば、ご教示いただけると幸甚です。

よろしくお願いします。

iMac (21.5-inch, Late 2015), OS X El Capitan (10.11.6)

投稿日

返信
スレッドに付いたマーク この回答で解決
回答:
回答:

/System/Library/StagedFrameworks/Safari内に、”WebKit.framework”と”WebKitLegacy.framework”がありました。

情報を見ると、前者はver 11604.4.7.1.3で後者はverv11064.4.7.1.4で、共に変更日はSafariのアップデートと同じタイミングでした。

FirefoxやSierra上のSafariでは問題なくアクセスできる以上、証明書自体の問題ではなく証明書の検証プロセスに問題(根本的にはOSのバグ?)があるようなので、El CapitanではFirefoxをメインに使うのが精神衛生上良さそうですね。


因みに、Lion上のSafari ver 6.1.6ではこの問題が起きません。 簡単に確認できるのはLion(何年も前にサポート終了)のみなので一概に云えませんが、ユーザー側で簡単に対処できるようなことではなさそうだと。

現象が確認できたのが、12月の第2週目の月曜日か火曜日辺りで、昨夜(8日)までは改善してたはずなので、その間に何が起きたのかわからない以上、頭を切り替えてFirefox使うのが週末を無駄にしない最善の対処方と思ってます。


さてと、何処に行こうか(現実逃避)……(笑)

投稿日

スレッドに付いたマーク 参考になった

2017/12/07 00:14 ガンダムユニコーン への返信 ガンダムユニコーン への返信

数日前に、特定のサイトにアクセスする際に同じ症状を体験しました。 ほっといたら数時間後に繋がるようになってましたが、サーバー側の都合としてます。

スレッドに付いたマーク 参考になった

2017/12/10 00:18 onesize への返信 onesize への返信

 システム情報のフレームワークを確認したところ、WebKitが2個あり、1個は7日のアップデートでsafariと一緒にインストールされたsafari用のようです。これの日付が2017/12/07になっています。私の環境ではこれがインストールされた後に問題が発生したのだと思います。昨晩解消された原因は判りませんが、認証情報取得の処理タイミングに問題があったのかも知れません。もしそうだとすると今後再発する可能性がありますね。

 FireFoxもWebKitを使用しているはずですが、もう一つの方を使用しているので問題なかったのでしょう。

ディスカッションを部分的に表示しています

返信をすべて表示

ページコンテンツが読み込まれました

2017/12/06 22:00 ガンダムユニコーン への返信 ガンダムユニコーン への返信

それはおそらくサイトの作り方で決まると思いますので、Safari を使う限りは手がないのではないでしょうか。もっともApple の仕様にサイトが対応しかねる場合、原因がサイトなのかApple なのかは一般ユーザーには判断しかねるのですが。

2017/12/06 22:00

返信 参考になった

2017/12/06 22:47 ni_ki への返信 ni_ki への返信

ni_ki様


ご回答いただきありがとうございました。


昨日までは正常に接続できていたので、サイトの作りではないと思います。

同様の症状になる他のサイトも、昨日までは正常に接続できています。

昨日から本日にかけて何か設定変更したものが無いか確認しているところですが、

NASのDLNA設定(サーバ機能offからonへ)をweb経由で設定したぐらいです。(NASはWiFiルータに有線接続でぶら下がっており、iMacも同じルータにぶら下がっています)

設定変更にはパスワード認証が必要になるのですが、その際に”セキュリティレベルを上げてアクセス”というボタンを押下した時、この警告を初めて見ました。この押下によってセキュリティに関する何らかの設定ができてしまったのではないかと調査しています。(・・・が、今の所、全然わかりません)


お付き合いいただき、ありがとうございました。

2017/12/06 22:47

返信 参考になった
スレッドに付いたマーク 参考になった

2017/12/07 00:14 ガンダムユニコーン への返信 ガンダムユニコーン への返信

数日前に、特定のサイトにアクセスする際に同じ症状を体験しました。 ほっといたら数時間後に繋がるようになってましたが、サーバー側の都合としてます。

2017/12/07 00:14

返信 参考になった (2)

2017/12/07 00:13 onesize への返信 onesize への返信

onesize様


ご回答いただき、ありがとうございます。

そういったケースもあるのですね。

しばらく時間をおいて症状を見てみます。

それでもダメならtimemashineかな。


お付き合いいただき、ありがとうございました。

2017/12/07 00:13

返信 参考になった

2017/12/07 00:19 ガンダムユニコーン への返信 ガンダムユニコーン への返信

ガンダムユニコーン さんによる書き込み:


昨日までは正常に接続できていたので、サイトの作りではないと思います。

それがサイトの作りの特徴です。過去にも度々ありました。

2017/12/07 00:19

返信 参考になった

2017/12/07 18:51 ni_ki への返信 ni_ki への返信

ni_ki様


コメントいただき、ありがとうございます。


他の方のコメントにもありましたが、サイト側の都合にも影響を受けるようですね。

もうしばらく様子を見てみます。


お付き合いいただき、ありがとうございました。

2017/12/07 18:51

返信 参考になった

2017/12/07 20:27 ガンダムユニコーン への返信 ガンダムユニコーン への返信

> ”接続がプライベートではありません”と表示され、目的のサイト(Tモール)に接続されません。


具体的に接続先をあげてもらえますか?

Tモールにつなぐだけなら、問題なく繋がりますし、証明書も怪しいものではありません。

証明書の発行者が不明なんて言われるのは怪しいです。偽サイトに繋がってる可能性があるのでは?

2017/12/07 20:27

返信 参考になった

2017/12/07 20:29 粕谷 明 への返信 粕谷 明 への返信

粕谷様


コメントいただき、ありがとうございます。

ご紹介いただいたものの内、最初から3行分については全て確認しましたが、改善しません。

接続できないサイトの1つは、TSUTAYAさんのTモール(ショッピングモール)です。

このサイトをsafariで検索してクリックしても同じ症状ですので、url指定ミスということもなさそうです。

VPN接続が必要なサイトとも思えません。

safariは今アップデート&再立ち上げしたところですが、症状は改善しません。

アンチウィルスソフトの設定も、正常に接続できていた一昨日と今とで変更していません。(自動アップデートで何かが変わっている可能性はあるのですが、今の所見つけられません)


SSL認証で問題が発生しているようで、「tmall.tsite.jp」に対して”この証明書の発行者は無効です”との表示が出ます。接続できない他のサイトについても同様の表示が出ます。

・・というところまではわかるのですが、だから何?というところで悶絶中です。


Quiteを試すのはちょっと勇気がいりますので、timemashineで昔の設定に戻してみようと思います。


お付き合いいただき、ありがとうございました。

2017/12/07 20:29

返信 参考になった

2017/12/07 20:43 ni_ki への返信 ni_ki への返信

 本日私もこのメッセージに遭遇しました。

 みずほ銀行の宝くじ当選番号案内のサイトです。

https://www.mizuhobank.co.jp/takarakuji/loto/loto6/index.html

 月曜日には普通にアクセスできていたのですが、今日El Capitanのシステムアップデート(safariを含むセキュリティアップデート)があった後で気が付きました。

FireFoxでは普通に表示できます。

それにしてもメッセージの意味が判らないですね。

2017/12/07 20:43

返信 参考になった

2017/12/07 21:12 はに への返信 はに への返信

はに様


コメントいただき、ありがとうございます。


接続できないサイトの1つは、TSUTAYAさんのTモールです。URLは、以下の通りです。

https://tmall.tsite.jp


>偽サイトに繋がってる可能性があるのでは?

非常にシンプルに、そうかもしれません。・・・が、腑に落ちないこともあります。


サイトへのアクセスですが、safariで”Tモール”と検索して一番上に表示されたものをクリックしたり、昔正常に接続できていた頃にブックマークにしたものをクリックしても、同じ症状です。

ちなみに、PSVITA、携帯電話ではうまく接続できており、そのURLは上記と同じものです。

PSVITA、携帯電話ともに、iMacと同じWiFiルータを使用しています。

不思議なことがもう一つあります。同一LAN内にあるNASの設定をiMacを使ってweb経由で行った際にも全く同じ症状が出ます。

ブラウザはsafariです。iMacとNASは、どちらも上述のWiFiルータに有線で接続しています。

”接続がプライベートではありません”の表示は、iMacを使い始めて、このNASの設定の時に、初めて、見ました。

これとの相関はわかりませんが、これ以降、Tモールなど幾つかの接続で同じ表示が出ています。


他の方のご助言もあり、appleサポート等での対処も確認しましたが、改善していません。

timemashineで正常だった頃に戻し、症状を見てみようと思います。


お付き合いいただき、ありがとうございました。

2017/12/07 21:12

返信 参考になった

2017/12/07 21:20 品川地蔵 への返信 品川地蔵 への返信

品川地蔵様


コメントいただき、ありがとうございます。


品川様がコメントされているサイトに私もアクセスしました。

結果、同じ症状が出ました。


safariが原因っぽいですね。


timemashineで昔の設定に戻せるなら、試そうと思います。

何かわかったらここに上げます。


お付き合いいただき、ありがとうございます。

2017/12/07 21:20

返信 参考になった

2017/12/07 22:15 ガンダムユニコーン への返信 ガンダムユニコーン への返信

> 接続できないサイトの1つは、TSUTAYAさんのTモール


うちでアクセスする限り正常に繋がり(macbook pro retina late 2013、sierra 10.12.6のsafari 11.0.2)、証明書の発行者が不明と言われることもなく、発行者はこの世界ではよく知られた認証機関のものでroot証明書もよく知られた機関のものです。

品川さんのあげられてるサイトも正常に繋がります。こちらも、よく知られた認証機関の発行した証明書です。

DNSキャッシュが汚染してて、サイトのアドレスがおかしくなっているという可能性はありませんか?最近、Apple社に関するバグが頻発して、その対策でアップデートもいっぱい出てますので、その加減でDNSキャッシュがおかしくなってしまっているという可能性もあるかもしれません。一方、世の中には、タチの悪いウィルスを撒いて、DNSキャッシュをわざと汚染して偽サイトに誘導するという手口もあります。NASが関係してる可能性に言及されてますが、NASのファームウェアアップデートとか出てませんか?もし出てればアップデートしておくことをお勧めします。DNSキャッシュが汚染する可能性はファームウェアの古いNASだと結構あるかもしれません。

DNSキャッシュが汚染してる場合には、DNSキャッシュをリセットする対策が有効かもしれません。

OS X で DNS キャッシュをリセットする - Apple サポート

あるいは、認証機関の公開証明書自体がおかしくなっている可能性はどうですか?

その場合は、認証機関の公開証明書がソフトウェアアップデートで更新されてる可能性もありますので、最近のソフトウェアアップデートを再度当てるのが良いかもしれません。

2017/12/07 22:15

返信 参考になった

2017/12/07 23:19 はに への返信 はに への返信

 safariのすべての履歴の削除、システムをセーフブートの後でもダメですね。同じシステム上のFireFoxでは問題ないこと、別のマック(High Sierra)のsafariでは問題ないことから、やはりこのバージョンのsafari( 11.0.2 (11604.4.7.1.4))が何かおかしな処理をしているとしか、今のところ思えませんね。

2017/12/07 23:19

返信 参考になった

2017/12/08 00:39 品川地蔵 への返信 品川地蔵 への返信

はに様、品川地蔵様


コメントいただき、ありがとうございます。


timemashineで1年前の状態に戻して確認したところ、同じ症状でした。

ただ、異常表示が現在と異なっており、そこに指示されている”無視して接続する方法”で接続したところ、正常に表示されました。なお、接続後はURLの先頭に鍵マークが出ません。SSL認証していないので当然ですね。

異常無視で一度アクセスすると、キャッシュのおかげか、その後は異常表示無しで接続されます。但し、SSL認証はされていません。

一昨日まではこの状態で利用していたのだと思います。だとしても、昨日からその状況が変化した原因は不明です。(何かの拍子にキャッシュが削除され、最新の異常表示・処理が作動したのかもしれません)


SSL証明書を確認したところ、サーバが使用している中間認証局は、iMacで保持している認証局@キーチェンアクセスの中に見当たりません。

サーバが使用している中間認証局は、上位がCybertrust Global Root、下位がCybertrust Japan EV CA G2です。

どちらも実在している局ですし、スマホで接続した際に照合している中間認証局は、この局です。

スマホが保持している局には、Cybertrust Global Rootが存在していますが、iMacにはこれが無いのです。

ひょっとすると中間認証局を表示する方法を私が知らないだけなのかもしれませんが、今の所見つけられていません。


仮に、iMacが上記中間認証局の情報を保持していなければ、認証できるはずがありません。

この場合、信頼できるところから中間認証局の情報をインストールする必要がありそうです。

方法があれば・・・ですが。


その前に、DNSキャッシュのリセットを試してみます。


お付き合いいただき、ありがとうございました。

2017/12/08 00:39

返信 参考になった
ユーザのユーザプロフィール: ガンダムユニコーン

質問: 接続がプライベートではありません